Технологии ввода графической, текстовой и речевой информации icon

Технологии ввода графической, текстовой и речевой информации




НазваниеТехнологии ввода графической, текстовой и речевой информации
Дата конвертации20.04.2015
Размер178.37 Kb.
ТипДокументы
источник

ТЕХНОЛОГИИ ВВОДА ГРАФИЧЕСКОЙ, ТЕКСТОВОЙ И РЕЧЕВОЙ ИНФОРМАЦИИ
Изучаемые темы:
1. Ввод графической и текстовой информации с использованием сканера.

2. Ввод речевой информации.

Тема № 1

Ввод графическОЙ И ТЕКСТОВОЙ ИНФОРМАЦИИ С ИСПОЛЬЗОВАНИЕМ СКАНЕРА
Вопросы: 1. Принцип работы сканера.

2. Сканирование графической и текстовой информации.
1. Принцип работы сканера
Сканер (от англ. scan - пристально разглядывать; бегло просматривать) - это устройство ввода текстовой или графической информации в компьютер путем преобразования ее в цифровой вид для последующего использования, обработки, хранения или вывода.

Сканер незаменим, если Вам нужно ввести в компьютер графику или тексты с бумажных носителей.

Принцип работы сканера заключается в следующем. На каретку, которая передвигается при помощи шагового двигателя, устанавливаются лампа подсветки и система зеркал. Свет от лампы на каждом шаге двигателя отражается от документа и через систему зеркал попадает на матрицу. Чувствительные элементы матрицы определяют интенсивность отраженного света путем преобразования в электрический сигнал. Затем аналоговый сигнал преобразуется в цифровой, обрабатывается и передается в компьютер для дальнейшего использования. Таким образом, на каждом шаге каретки сканер фиксирует одну горизонтальную полоску оригинала, разбитую в свою очередь на некоторое количество пикселов. Итоговое изображение представляет собой как бы мозаику, составленную из пикселов одинакового размера и разного цвета.

В комплекте со сканером Вы получаете программное обеспечение. И первое, что обязательно идет в комплекте со сканером, - это его Twain-драйвер.

Twain-драйвер - это приложение с графическим интерфейсом, которое исполняет функции панели управления сканером и передает от него данные в программное приложение, в котором Вы работаете. С помощью Twain-драйвера производится установка параметров и области сканирования, предварительное сканирование и просмотр, обеспечивается возможность цветокоррекции и постобработки получаемого изображения.

Ввод графических изображений в компьютер осуществляется с помощью графического пакета. В настоящее время со сканерами поставляются продукты таких фирм, как Adobe (Photoshop), Ulead (Image Palsgo, iPhoto Plus, iPhotoExpress), Micrografx (Picture Publisher) и некоторые другие. В России наиболее популярен пакет Adobe Photoshop. Для выбора источника Twain используется команда Select Sourse в меню File. Для вызова сканера используется команда Acquire из меню File.
2. Сканирование графической и текстовой информации
Для того чтобы отсканировать графическое изображение (фотографию, картинку и т.п.), поместите это изображение под крышку сканера и, нажав кнопку Пуск, выберите в главном меню Программы\Adobe\Adobe Photoshop. В результате появится окно Adobe Photoshop (рис. 1), в котором в меню Файл выберите пункт Импортировать и в открывшемся списке команду Twain. На экране появится окно ScanExpress (рис. 2), в котором Вы можете выбрать цвет рисунка (Scan Mode), источник (Scan Sourse), размер (Scan Size), разрешение (Resolution), масштаб сканирования (Scaling), ширину (Widhth) и высоту (Height) изображения в дюймах или сантиметрах. Кликните на кнопке Scan, и через некоторое время отсканированное графическое изображение появится у Вас на экране. Закрыв окно сканирования, Вы окажетесь в окне Adobe Photoshop (рис. 3), в котором можете продолжить работу с отсканированным изображением (изменять размер, редактировать, сохранять в различном формате и т.д.).

Следует заметить, что сканер создает лишь фотографию исходного изображения. Такую фотографию – набор точек, или, иначе говоря, графический файл, - нельзя редактировать в текстовом редакторе MS Word, MS Excel и т.д. Поэтому если Вам необходимо ввести со сканера в компьютер текст, то Вам потребуется программа оптического распознавания текстов, которая обнаружит в наборе точек отдельные знаки и в каждом знаке “узнает” ту или иную букву алфавита. Одной из таких программ является программа оптического распознавания FineReader, предназначенная для автоматического ввода документов в компьютер.

Для того чтобы ввести текст в текстовый редактор положите страницу с текстом в сканер. Запустите программу FineReader, для чего нажав кнопку Пуск, выберите в главном меню Программы/ABBYY FineReader 7.0/ ABBYY FineReader 7.0 Professional Edition. Появится окно FineReader 7.0-Пакет (рис. 4), в котором нажмите на кнопку Scan&Read, в результате чего через несколько секунд появится окно Изображение, содержащее “фотографию” страницы. После этого программа автоматически перейдет к сегментации изображения, выделяя участки с текстом и таблицы, а затем – к распознаванию, закрашивая обработанные участки. С помощью кнопки Проверить Вы можете проверить результаты распознавания и отредактировать распознанный текст. Для того чтобы передать распознанный текст в MS Word, MS Excel и т.п., нажмите кнопку Сохранить и в появившемся меню выберите пункт Сохранить в файл… . Программа автоматически предложит сохранить результат как файл формата .doc. Этот формат позволяет сохранить не только текст, но и всю информацию об оформлении документа, а также картинки и таблицы.

Программа FineReader позволяет распознавать тексты на русском, английском, французском, немецком, испанском, итальянском, шведском и других языках, а также тексты, в которых встречаются любые комбинации поддерживаемых языков. Кроме того, встроенный текстовый редактор позволяет устанавливать шрифт, размер шрифта, форматировать текст и абзацы, проверять орфографию, автоматически создавать разные текстовые стили для абзацев с разным начертанием шрифта и т.п. С помощью этой программы Вы можете распознать многоколоночный текст с картинками и таблицами, сохраняя оформление и раскладку распознанной таблицы, распознать цветные изображения, осуществить поворот изображений на 90, 180 и 270 градусов и многое другое.

Контрольные вопросы




  1. Что такое сканер?

  2. Объясните принцип работы сканера.

  3. Что такое Twain-драйвер и для чего он используется?

  4. Какие графические (текстовые) пакеты используются при работе со сканером?

  5. Как отсканировать графическое изображение?

  6. Что нужно сделать для того, чтобы ввести текст со сканера в текстовый редактор?

Тема № 2

ВВОД РЕЧЕВОЙ ИНФОРМАЦИИ
Вопросы: 1. Общие сведения о системе автоматического распознавания речи

Горыныч.

2. Ввод речи с помощью программы Горыныч.
1. Общие сведения о системе автоматического распознавания речи Горыныч
Система автоматического распознавания речи Горыныч позволяет диктовать компьютеру по-русски и по-английски для быстрого введения текстов в компьютер в текстовом редакторе Word for Windows или Notepad. Скорость ввода текста в компьютер составляет примерно 600 – 7000 знаков в минуту. При этом в текстах исключаются орфографические ошибки. Кроме того, при помощи данной программы можно контролировать компьютер голосовыми командами. Программа поддерживает словарь в 10000 русских и столько же английских слов.

Для установки программы запустите из-под Windows файл setup. В появившейся панели (рис. 5) войдите в меню Voice Menu и выберите в нем опцию Options. Среди появившихся закладок (рис. 6) найдите Correction, Voicebar и Voc.Manager и поменяйте в них размер шрифта на 14. В закладке Start Up выставьте флажок микрофона на ON, а в закладке Recognition переместите курсор самой верхней панели Computation Level до конца вправо, что позволит добиться наилучшего качества распознавания. Позже, при хорошем качестве распознавания (когда система адаптируется к Вашему голосу), Вы можете переместить этот курсор левее для более быстрого распознавания. После этих установок нажмите на кнопку ОК.

Для запуска программы в меню Voice menu выберите опцию Tools, а затем Vocabulary Manager. На экране появится диалоговое окно Vocabulary Manager, в котором имеются две панели с папками (рис. 7). На левой панели, среди красных папок, выберите папку System, при этом появятся желтые папки. Выберите среди них папку Always Active и откройте ее. Вы увидите пять команд (рис. 8): Command mode (Режим команд), Dictate mode (Буду диктовать), Go to Sleep (Отдыхай), Oops (Упс), What Can I Say. Далее, выбрав первую команду Command mode, нажмите кнопку Traine и произнесите на русском языке словосочетание “Режим команд” столько раз, сколько будет требовать программа (при этом следите за кружками с индикаторами – при произнесении они окрашиваются в зеленый цвет). Пройдите данный тест дважды. В правом верхнем углу, при повторном прохождении теста, Вы увидите аналог команды на английском языке (в данном случае – Command mode). После этого войдите в меню Voice menu, выберите в нем опцию Quick Access и запомнитесь с помощью команды Save User. По аналогии проделайте все то же самое с остальными командами, кроме последней (она нас не интересует). После этого выберите те приложения, которые Вы хотите открывать, например Notepad (команда Блокнот), Microsoft Word (команда Новый документ) и т.д. и проделайте туже операцию с тренингом, которая была описана выше, не забывая при этом запоминаться (командой Save User опции Quick Access меню Voice Menu). Затем в паке System найдите папку Global Commands и выберите команду Bring up (произнести «Открыть»), а в папке Sleeping – команду Wake up (произнести «Проснись»).

После этого Вы можете приступать к работе, для чего можете воспользоваться Быстрым стартом, который включает в себя голосовые команды: ПроснисьОткрытьБлокнот (для работы с Блокнотом) или Новый_документ (для работы с Microsoft Word) – Буду_диктовать.

Активизировать подключенный микрофон можно щелчком мышки по его изображению в верхней части экрана. Дальнейшее включение и выключение микрофона осуществляется мышкой. Выведение программы из режима “сон” осуществляется командой Проснись, дезактивация микрофона производится командой Отдыхай. В режиме “сон” индикатор состояния микрофона окрашен в серый цвет и Вы видите надпись “Sleeping”. В активном состоянии индикатор микрофона становится желтым, а когда Вы начнете говорить, он станет зеленым (при этом не допускайте появление красного цвета, поскольку это говорит о слишком высоком уровне входного сигнала). Во время работы можно пользоваться клавиатурой и мышкой. Они блокируются лишь в те мгновения, когда Вы что-либо говорите.
2. Ввод речи с помощью программы Горыныч
Перед тем как начать диктовку проверьте, хорошо ли у Вас настроен микрофон. Для этого можно воспользоваться тестом, автоматически настраивающим микрофон и запускаемым командой Microphone Volume Setting из подменю Tools меню Voice menu. Запустив тест, Вам достаточно произнести несколько раз обычным голосом “тестирую микрофон”. При этом после каждой фразы-теста надпись «Testing microphone» будет бледнеть, и Вам следует сохранять максимальную тишину до ее следующего появления. По окончании теста компьютер скорректирует уровень входного сигнала микрофона с громкостью и модуляцией Вашего голоса и с учетом внешнего уровня шума. При этом кнопка ОК станет доступной. В том случае, если данная настройка не даст результатов, существенно улучшающих распознавание, можно попытаться вручную отрегулировать уровень сигнала микрофона, воспользовавшись кнопкой Пуск и пунктами главного меню Windows 95 ПрограммыСтандартныеРазвлечения - Регулятор громкостиПараметрыСвойства (в двух последних - все что касается микрофона).

Говорить в микрофон следует нормальным голосом. При этом не старайтесь выговаривать слова. Программа Горыныч адаптирована к наиболее распространенному произношению слов. Чем чаще Вы диктуете, тем больше система привыкает к Вашему голосу и тем быстрее и точнее распознает текст. После окончания работы с программой, она всегда предлагает Вам сохранить библиотеку Ваших произношений. Если Вы при диктовке допустили ошибки, которые были поправлены Вами не голосом или мышкой, а с клавиатуры, то откажитесь от запоминания в конце работы. В противном случае программа начнет накапливать Ваши ошибки в произнесении слов. Это касается также случая, когда посторонние звуки вызвали во время Вашей работы появление на экране большого количества случайных слов. Если же Вам приходится работать в условиях крайней зашумленности, то передвиньте курсор опции Background Noise Level (меню Voice menu опция Options, закладка Recognition) ближе к правому краю, - это даст Вам возможность работать даже на фоне разговоров и посторонних звуков.

Если Вы хотите иногда диктовать и по-английски, то создайте пользователя с любым именем, под которого автоматически будут загружены английские словари. Для создания этого пользователя в меню Voice menu откройте панель Users и щелкните мышкой на клавише Create User. Пройдя два теста микрофона и мини-тренинг с несколькими английскими словами, Вы получите возможность, переключаясь на этого пользователя командой Switch to User, диктовать тексты по-английски.

Ниже в таблице 1 приведены команды для работы с программой Горыныч и описание действий каждой команды. При этом команды, состоящие из двух и более слов следует произносить слитно. В таблице данные команды соединены символом подчеркивания (_).

Таблица 1

Команда

Действие команды

1. Глобальные команды

Проснись

Активизирует микрофон (в меню – Wake up)

Отдыхай

Переводит микрофон в режим ожидания (в меню – Go to sleep)

Выключить_микрофон

Полностью выключает микрофон. Снова включить его можно только мышкой

Открыть

Вызывает программы (в меню – Bring up)

Открыть_новый_документ

Открывает программу Word for Windows

Блокнот

Вызывает текстовый редактор Блокнот (в меню - Notepad)

Калькулятор

Вызывает калькулятор (в меню – Calculator)

Эмэсдос

Обеспечивает временный выход в MS DOS (в меню – Сеанс MS-DOS)

Буду_диктовать

Переводит из режима команд в режим диктовки (в меню – Dictate Mode)

Режим_команд

Возвращает в режим команд (в меню – Command Mode)

Упс

Вызывает меню для правки нескольких последних сказанных слов (в меню – Oops)

Свернуть

Сворачивает окно текущего приложения (в меню – Свернуть)

Развернуть

Разворачивает во весь экран окно текущего приложения (в меню – Развернуть)

Восстановить

Восстанавливает стандартный размер окна текущего приложения из состояния полноэкранного окна (в меню – Восстановить)

Закрыть_окно

Закрывает окно любого приложения (в меню – Close Window)

Да

Соответствует нажатию клавиши Enter

Отмена

Соответствует нажатию клавиши Esc

Удалить

Соответствует нажатию клавиши Del

Системное_меню

Вызывает меню всего окна в целом в любом приложении (в меню – System Menu)

Вниз, Вверх, Вправо, Влево

Перемещает курсор по тексту меню, объектам, полям (в меню – Down, Up, Right, Left)

2. Команды режима диктовки

Большими_буквами

Все следующее слово будет напечатано заглавными буквами

С_большой_буквы

Будет поднята первая буква в следующем слове

С_маленькой_буквы

Следующая заглавная буква будет напечатана как строчная

Стереть_слово

Будет стерто последнее напечатанное слово

Без_пробела

Не будет пробела перед следующим словом

Абзац

Переход на новую строку (абзац)

Точка

Будет напечатана точка (.)

Запятая

Будет напечатана запятая (,)

Восклик

Будет напечатан восклицательный знак (!)

Знак_вопроса

Будет напечатан знак вопроса (?)

Кавычки

Будет напечатан знак открытия кавычек (“)

Закрыть_кавычки

Будет напечатан знак закрытия кавычек (”)

Многоточие

Будет напечатан знак многоточия (…)

Двоеточие

Будет напечатано двоеточие (:)

Точка_с_запятой

Будут напечатаны точка с запятой (;)

Тире

Будет напечатано тире (-)

Левая_скобка

Будет напечатан знак открывающейся круглой скобки (

Правая_скобка

Будет напечатан знак закрывающейся круглой скобки )

Примечание. Для введения числа достаточно назвать составляющие его арабские цифры. Римские цифры вводятся только с клавиатуры. Порядковые числительные доступны от одного до десяти во всех падежах.

3. Команды, используемые при работе с Блокнотом


(Запуск: Проснись – Открыть – Блокнот – Буду_диктовать)

а) Специальные команды

Файл

Работа с документом в целом

Правка

Работа с частями и элементами документа

Поиск

Поисковая система Блокнота

Помощь

Открывает меню справки

б) Команды из меню Файл (меню должно быть открыто)

Создать

Создает новый документ

Открыть

Открывает документ

Закрыть

Закрывает документ

Сохранить

Сохраняет текущий документ

Сохранить_как

Сохраняет документ с новым именем

Макет_страницы

Позволяет вводить параметры страницы текущего документа

Печать

Выводит на печать текущий документ

Выход

Выходит из Блокнота

в) Команды из меню Правка (меню должно быть открыто)

Вырезать

Вырезает фрагмент текста

Копировать

Копирует фрагмент текста в буфер

Вставить

Вставляет фрагмент текста из буфера

Удалить

Удаляет выделенный фрагмент текста

Выделить_все

Выделяет весь текст в документе

Перенос_по_словам

Форматирует текст по размеру окна Блокнота

г) Команды из меню Поиск (меню должно быть открыто)

Найти

Открывает окно поиска слова в документе

д) Команды из меню ? и Помощь (меню должно быть открыто)

Вызов_справки

Вызывает справку о Блокноте

Примечание. Команды Да, Нет, Отмена используются при работе с меню запросов на исполнение.

4. Команды, используемые при работе в WinWord


(Запуск: Проснись – Открыть – Новый_документ – Буду_диктовать)

а) Специальные команды

Файл, Правка, Вид, Вставка, Формат, Сервис, Таблица, Окно, Помощь

Осуществляют навигацию по верхнему меню (по названиям)

б) Команды из меню Файл (меню должно быть открыто)

Создать

Создает новый документ

Открыть

Открывает документ

Закрыть

Закрывает текущий документ

Сохранить

Сохраняет текущий документ

Сохранить_как

Сохраняет документ с новым именем

Параметры_страницы

Позволяет вводить параметры страницы текущего документа

Предварительный просмотр

Позволяет произвести предварительный просмотр страницы документа перед отправкой на печать

Печать

Выводит на печать текущий документ

Выход

Выходит из WinWord

в) Команды из меню Правка (меню должно быть открыто)

Вырезать

Вырезает фрагмент текста

Копировать

Копирует фрагмент текста в буфер

Вставить

Вставляет фрагмент текста из буфера

Удалить

Удаляет выделенный фрагмент текста

Выделить_все

Выделяет весь текст в документе

г) Общие команды (не требующие вхождения в меню)

Синонимы

Вызывает словарь синонимов

Выделить_слово

Выделяет слово, рядом с которым стоит курсор

д) Команды работы со шрифтами (слова или части текста должны быть выделены)

Жирный_шрифт

Использует жирное начертание слов

Курсивом

Использует начертание слов курсивом

Нормальный_шрифт

Использует начертание слов нормальным шрифтом

Подчеркнуть

Подчеркивает слово

Сделать_шрифт_больше

Увеличивает размер шрифта

Сделать_шрифт_меньше

Уменьшает размер шрифта

Изменить_шрифт

Вызывает меню шрифтов

5. Команды, используемые при работе с Калькулятором


(Запуск: Открыть – Калькулятор)

Плюс

Соответствует знаку сложения

Минус

Соответствует знаку вычитания

Умножить

Соответствует знаку умножения

Разделить

Соответствует знаку деления

Равно

Соответствует знаку равенства

Назад

Стирает последнюю введенную цифру

Запятая

Соответствует знаку отделения целой части от дробной при вводе цифр

Сброс

Соответствует функции С на калькуляторе

Примечание. Все цифры от 1 до 10 вводятся как в режиме диктовки.

6. Команды управления мышью

Мышь_вверх, Мышь_вниз, Мышь_вправо, Мышь_влево, Мышь_вверх_вправо, Мышь_вниз_вправо, Мышь_вверх_влево, Мышь_вниз_влево

Управляют движением мыши

Стоп, Быстро, Очень_быстро, Еще_быстрее, Медленно, Очень_медленно, Еще_медленнее

Управляют скоростью движения мыши

Левая_кнопка, Правая_кнопка, Двойной_щелчок

Управляют кнопками мыши

Тащи_вверх, Тащи_вниз, Тащи_вправо, Тащи_влево, Тащи_вниз_влево, Иащи_вниз_вправо, Тащи_вверх_влево, Тащи_вверх_вправо

Осуществляют перетаскивание объекта мышью

Отметь_место

Отмечает объект для перетаскивания

Тащи_сюда

Отмечает место, куда перетаскивать помеченный объект




Контрольные вопросы




  1. Дайте общую характеристику системе автоматического распознавания речи Горыныч.

  2. Как установить программу Горыныч?

  3. Что нужно сделать для запуска программы?

  4. Как проверить настройку микрофона?

  5. Что нужно сделать для того, чтобы диктовать текст на английском языке?

  6. Какие глобальные команды используются при работе с программой Горыныч?

  7. Какие команды режима диктовки (управления мышью) используются при работе с программой Горыныч?

  8. Какие команды используются при работе с блокнотом (текстовым редактором Word, калькулятором) в системе автоматического распознавания речи Горыныч?



Похожие:

Технологии ввода графической, текстовой и речевой информации iconУрок 11 Тема: Таблицы Повторим? Расскажите о текстовой форме представления информации
Прочитай внимательно текст «Оценки за год». Ответьте на вопросы к тексту Таблица простая и удобная форма представления однотипной...
Технологии ввода графической, текстовой и речевой информации icon«Обработка текстовой информации»
Текст, набранный в тестовом редакторе, храниться на внешнем запоминающем устройстве
Технологии ввода графической, текстовой и речевой информации icon1. Устройствами ввода информации являются
Программа, хранящаяся во внешней памяти, после вызова на выполнение попадает в и обрабатывается
Технологии ввода графической, текстовой и речевой информации iconПеречень компетенций учителя-предметника в сфере икт
Наличие представлений о едином информационном пространстве образовательного учреждения, назначении и функционировании пк, устройствах...
Технологии ввода графической, текстовой и речевой информации iconЭкзаменационные билеты по информатике и информационным технологиям к устной итоговой аттестации выпускников 11 класса. Билет №1
Понятие информации. Виды информационных процессов. Поиск и систематизация информации. Хранение информации; выбор способа хранения...
Технологии ввода графической, текстовой и речевой информации iconСтандарт начального общего образования по технологии
Простейшие приемы поиска информации: по ключевым словам, каталогам. Соблюдение безопасных приемов труда при работе на компьютере;...
Технологии ввода графической, текстовой и речевой информации iconОбщие положения Web-сайт предназначен обеспечить
Представление официальной информации на Web-сайте соответствует порядку представления официальной информации в средствах массовой...
Технологии ввода графической, текстовой и речевой информации iconДокументы
1. /Примеры оформления графической части/Раздел 2 (анализ)/2.1.doc
2. /Примеры...

Технологии ввода графической, текстовой и речевой информации iconУрок русского языка по теме: «имя прилагательное» 3класс умк «Начальная школа XXI век»
Технологии: элементы игровой технологии, элементы технологии развивающего и дифференцированного обучения
Технологии ввода графической, текстовой и речевой информации iconУчебник: Кравченко, Мясников «Инфотелекоммуникационные технологии»
Система передачи информации состоит из источника ее, канала связи и получателя. Источник записывает информацию в определенном алфавите,...
Разместите кнопку на своём сайте:
Документы


База данных защищена авторским правом ©ex.kabobo.ru 2000-2014
При копировании материала обязательно указание активной ссылки открытой для индексации.
обратиться к администрации